Glade Reference


Change Log 2018

Contents for 2017 can be found here

 

Version 4.6.27 release on 07/01/2018

- bugfix: Schematic Create Layout dialog did not set current library to that of the current cellView.

- bugfix: Import EDIF failed on some examples.

- bugfix: Invalid instance pins could cause an exception, now more gracefully handled.

- enhancement: improvements to arc drawing code.

- bugfix: Create CellView added cellName to NLPDeviceFormat property, now uses [@modelName]

- enhancement: Export CDL now supports using NLPDeviceFormat property on extraction PCells for user-defined netlist formatting.

 

Version 4.6.28 release on 21/01/2018

- bugfix: File->Exit with edited cells did not cancel if 'Cancel' button clicked.

- bugfix: Export CDL from extracted view with parasitics reported parasitics twice if 'merge parasitics' selected.

- enhancement: Added Cancel button to Create Instance dialog.

- enhancement: Added defaultParams property setup for Create CellView from CellView command..

- enhancement: Added Cross View Check to Schematic->Check and Symbol->Check menus. Checks that each view of a library cell has same number of pins, there are matching pin names, and pin directions match.

- bugfix: Import EDIF was incorrectly overwriting schematic info into symbol views since last version.

 

Version 4.6.29 release on 28/01/2018

- bugfix: Fixed a crash if e.g. Create Via bindkey (v) clicked while in symbol editor.

- enhancement: Added instName Spice prefix support for device types 'vsrc', 'isrc'.

- enhancement: Added 'Descend Read' / 'Descend Edit' option to Descend Hierarchy dialog.

- enhancement: Descend Hierarchy pre-seeds view name option to current view name.

- enhancement: Export CDL dialog remembers last switch list name setting.

- enhancement: PCell submaster names are now of the form <cellName>$$12345678, where the number is a hashed string result. This removes an issue where long PCell submaster names caused issues with filesystems with 256 character limits, such as Windows.

- enhancement: Added option to open new cellView when created using library browser or File->New Cell...

- enhancement: Create Symbol now has pins displayed in a table for easier setting of side. Pin style feature added for e.g. inverted or clock pins.

- enhancement: Create Symbol has user defined wire stub length and pin size options.

 

Version 4.6.30 release on 03/02/2018

- enhancement: Allow specification of NLP netlisting format property name in Export CDL dialog.

- bugfix: vsrc/isrc instName Spice prefix support was broken in Schematic->Check.

- bugfix: Map table entries for schematic Layout->Map Devices could be shown multiple times. Now duplicate entries eliminated when opening a library.

- bugfix: Create Inatance dialog did not show all views of a cell sometimes.

 

Version 4.6.31 release on 09/02/2018

- enhancement: Export CDL dialog allows replacing bus delimiter characters '<' and '>' with alternative characters.

- bugfix: Generate Layout did not preserve pin directions from netlist/schematic.

- enhancement: Net Browser is refreshed when running Schematic->Generate Layout.

- enhancement: Create Label in layout allows a space-delimited list of label names (as in schematics); every left click will pop a label name off the list, and the command will repeat until all label names are generated.

- enhancement: Create Pin layout dialog simplified by merging pin name and net name into one.

- bugfix: Fixed a bug moving/copying arrays.

 

Version 4.6.32 release on 16/02/2018

- enhancement: Internal property list code streamlined.

- enhancement: Python function getPropList() implemented for dbObj derived classes to get a Python list of properties.

- bugfix: Exporting GDS2 with via objects could create multiple STRUCT definitions.

- enhancement: Export GDS2 can now export PCell property information if desired. Import GDS2 can read this information to allow PCell info to be saved/restored via GDS2. Note that this info is exported as GDS2 properties, and may be incompatible with other GDS2 readers. It has been tested with Cadence which can read this GDS2 however use at your own risk.

 

Version 4.6.33 release on 23/02/2018

- bugfix: dbFindProp() caused a crash if object had no properties.

- bugfix: Fixed a potential crash if objects selected in the gui were deleted using Python scripts.

- bugfix: Creating an instance of a schematic view within a schematic was possible; now a warning is given and the command is aborted (only symbols can be placed in schematics).

- bugfix: Fixed a bug in Import EDIF which could give incorrect property name/values.

 

Version 4.6.34 release on 03/03/2018

- bugfix: Export CDL dialog split into 2 tabwidgets so make it easier to use on low resolution screens.

- bugfix: Display Options->Miscellaneous->AutoRaise now controls focus grabbing by the application under all cases. Turning it off means Glade will lose focus after e.g. export/import or other commands that display a dialog. Useful if e.g. launching another application from Glade.

- bugfix: Help Browser Previous/Next button icons missing.

- enhancement: Help Browser now displayed via F1 key.

 

Version 4.6.35 release on 17/03/2018

- bugfix: Export CDL (using hierarchical netlister) uses NLPDeviceFormat property from symbol view if stop view does not have that property present.

- bugfix: Crash could occur for importing Calibre/Hercules errors if no valid cellView was open.

- bugfix: fixed a crash reporting schematic check shorts between instance pins.

- bugfix: fixed a crash in short tracer

- bugfix: fixed a crash in Netlist Window -> Generate Layout

- bugfix: Fixed a potential crash in e.g. schematic Check command, export CDL, export Verilog.

 

Version 4.6.36 release on 23/03/2018

- bugfix: Copying schematic instances did not set the instance name to spice compatible.

- bugfix: Entering schematic instances uses separate count for different spice-type elements, if symbols have the 'type' property set.

 

Version 4.6.37 release on 30/03/2018

- bugfix: Fixed a crash importing Cadence techfiles with standardViaDefs.

- bugfix: Crash on schematic check when no labelled nets or IO pins.

- bugfix: Selection mode was not shown when a window was opened, until the F4 (toggle selection mode) key was used. Now it is shown immediately the first cellView is opened.

- bugfix: Reading Oasis cell placements with negative angles gave incorrect results.

- bugfix: Setting width/height if schematic->Layout->Generate Layout value was scaled by 0.16

- bugfix: Fixed a trapezoid generation bug in geometry engine

- enhancement: Create Instance dialog populated only with views applicable to viewType of current cellView (symbol for schematic viewTypes; maskLayout for maskLayout viewTypes)

- enhancement: Added geomAddShape() / geomAddShapes() commands to create edgefile data for boolean engine from shape objects.

 

Version 4.6.38 release on 07/04/2018

- bugfix: LSW Display CellView Layers / Display Viewport Layers was not updating LSW when switching designs.

- bugfix: Dynamic adjustment of shape buffers for geomLabel to prevent a crash.

- bugfix: gemini can handle continuation characters in .subckt lines - no longer drops ports

- bugfix: gemini was not scaling units in .err file correctly.

- enhancement: Added geomStartPoly() / geomAddPoly() commands to create polygon edgefile data for boolean engine from lists of vertices.

- enhancement: Dynamic net highlighting added for schematics. Use the View->Selection Options dialog option to enable it.

- bugfix: switching tabs/windows could shift canvas towards bottom left.

 

Version 4.6.39 release on 15/04/2018

- bugfix: Fixed a potential crash on exit after deleting an object.

- enhancement: Can delete a wire segment in schematics. Select segment using partial select mode.

- bugfix: Backed up a change in trapezoid algorithm that caused several side effects.

 

Version 4.6.40 release on 20/04/2018

- bugfix: Fixed a bug where display for OpenGL canvas was inverted on window fit command.

- enhancement: Duplicate DRC markers removed after Verify->DRC->Run DRC...

- bugfix: dynamic highlight was not highlighting paths correctly when only path outlines enabled.

 

Version 4.6.41 release on 29/04/2018

- enhancement: Shape setNet() now removes the shape from it's net, and adds the shape to the new net, so a separate call to addShape() is not required.

- enhancement: dbMergeNet() command for merging a net into another net, handling net shapes, pins and instPins.

- bugfix: Improved schematic extraction performance.

 

Version 4.6.42 release on 05/05/2018

- bugfix: Fixed a potential crash when copying cellViews, if they contained references to unbound instances.

- bugfix: Fixed an issue with device extraction which gave incorrect W/L etc. if dbu was not 1/dbuPerUU (microns)

 

Version 4.6.43 release on 19/05/2018

- bugfix: Fixed a possible crash when re-running extraction.

- enhancement: added ui closeCellView(libName, cellName, viewName) python binding. Closes the named cellView window if open. The cellView remains in VM.

- bugfix: Fixed a possible crash in dbCreateNet()

- bugfix: Fixed a bug with extraction where bus names were badly formed.

 

Version 4.6.44 release on 20/05/2018

- bugfix: Array bounding box was not calculated correctly

 

Version 4.6.45 release on 27/05/2018

- bugfix: Application window was not initially receiving focus, causing e.g File-> bindkeys not to work until a design window was opened.

- bugfix: Performance issues in geomConnect() and saveInterconnect()

 

Version 4.6.46 release on 03/06/2018

- enhancement: PCells can be loaded / modified using compiled Python code (.pyc files) allowing them to be distributed without source code.

- bugfix: Create Instance dialog allowed same cell name as current cell in cellName chooser.

- bugfix: Create Instance dialog didn't remember last cellName/viewName on repeat.

- enhancement: New function geomAreaIn() which checks area of shapes and flags those where (minarea > area) && (area < maxarea) i.e. the opposite of geomArea().

 

Version 4.6.47 release on 08/06/2018

- bugfix: Stretch vertex for path beginning / ends now honors diagonal snapping correctly.

- bugfix: Stretch of diagonal segment of path/line/mpp with lock45 sometimes failed.

- bugfix: Stretch of diagonal segment of polygon with lock45 did not maintain diagonal.

- bugfix: Stretch vertex did not snap to manhattan correctly in manhattan mode.

 

Version 4.6.48 release on 24/06/2018

- bugfix: Entering paths with stacked vias gave 1-point paths on the intermediate metal layers in the via stack. Now the Create Path command removes 1 point paths.

- enhancement: Improved schematic autorouter to avoid parallel coincident wires

- enhancement: Added ui::routeWire(startPt, stopPt, netName) Python API for point to point schematic autorouting.

- enhancement: Coordinate precision reported in status bar now depends on dbuPerUU of displayed cellView. For example, with 1000 dbuPerUU, 3 decimal places are reported; with 2000 dbuPerUU, 4 decimal places are reported. Schematic views with 160 dbuPerUU and userUnits of inches are reported to 5 decimal places.

- bugfix: Dock windows maintain size.

- bugfix: Create Polygon using trueColour mode was not using layer colour/fill.

- bugfix: Chop cmd using trueColour mode was using layer colour/fill for chop rectangle rather than outline.

 

Version 4.6.49 release on 06/07/2018

- bugfix: Creating a PCell supermaster set bounding box to 5x5um unnecessarily. Now sets actual bounding box.

- enhancement: Generate Layout from netlist will check if subcircuits (X devices in netlist) are present. If an X device has a master cell in the library with view "layout" then an instance of that cell will be created in the generated layout.

- enhancement: Generate Layout from schematics will ignore an instance if it has a 'nlAction' string property with value 'ignore'

 

Version 4.6.50 release on 18/07/2018

- bugfix: Paths of type TRUNCATE did not have bounding box calculated correctly if the first vertex was greater than the last. This could cause display issues.

- enhancement: Import Cadence techfile reads MPP definitions.

 

Version 4.6.51 release on 29/07/2018

- enhancement: Improved Find command. Multiple search criteria can be added. Objects can be searched for e.g. shapes by layer and/or attributes and properties. Objects that have been found can have their attributes/properties changed.

- bugfix: Fixed a crash when in immediate mode and performing repeated stretch / select edge operations.

 

Version 4.6.52 release on 05/08/2018

- enhancement: Glade checks to see if it's the current version and warns if not. The checking can be disabled by setting the environment variable GLADE_NO_CHECK_VERSION. It does not attempt to download a new version - this must still be done manually.

- bugfix: Fixed a crash if the Create Layout command was issued from a design which had no PCell library for devices.

- bugfix: Moving instances with no shapes in first level of hierarchy did not show instance outline.

- bugfix: Creating an array had an offset between dynamic outline shown and final position of the array.

- bugfix: Flattening an instance containing rotated instances in 'to level' mode did not give correct orientation of child instances.

- bugfix: inst::updateBbox() gave incorrect bbox.

- bugfix: Editing properties for INST did not change X/Y origin.

- bugfix: Display Options 'RMB mode' was reset to 'Glade' on closing the dialog.

-enhancement: OpenGL display code uses fast triangulation algorithm instead of glu tesselator.

 

Version 4.6.53 release on 13/08/2018

- bugfix: Fixed several issues with yank/paste, especially with arrays.

- bugfix: Fixed an issue drawing a selected arc in symbol editor.

- Ubuntu 18.04 support. Uses native python 2.7 installation.

- dbHierObj was not exposed in thhe SWIG API, and now is.

 

Version 4.6.54 release on 27/08/2018

- bugfix: Fixed an issue with SWIG wrapping of dbHierObj

- bugfix: Fix a performance issue with large flat data.

 

Version 4.6.55 release on 05/09/2018

- bugfix: Colinear vertices on any angle edges now removed for polygons and paths.

- bugfix: Windows busy cursor was displayed even when drawing thread had completed. Now cleared correctly.

- bugfix: When in partial select mode, and using area select, the number of selected items could be incorrect.

- bugfix: Fixed a hang if creating an array of schematic instances.

- enhancement: Schematic Create Symbol dialog allows pins to be ordered. The ordering is used to control the pin positions in the resulting symbol.

- enhancement: Schematic Create Symbol checks to see if a cellView has been modified before creating a symbol.

- bugfix: CDL netlisting with long *.PININFO would use a '+' for continuation lines. Now writes a *.PININFO for each continuation line.

- bugfix: Edit In Place stretch cmd gave incorrect results for certain orientations.

- bugfix: Fixed a performance issue with designs containing many labels.

 

Version 4.6.56 release on 29/09/2018

- bugfix: Schematic text was not shown unless the filter size was set much larger than desirable.

- bugfix: Past in schematics crashed if pasting an ellipse/circle.

 

Version 4.6.57 release on 02/10/18

- bugfix: Labels not displayed in layout.

- bugfix: Selected shapes could have incorrect selection highlighting.

 

Version 4.6.58 release on 14/10/2018

- bugfix: Stream reader/writer crash if a null filename supplied.

- bugfix: Labels scaled based on zoom for layout only, so when zoomed out they are correctly filtered. Schematic/symbol labels remain fixed size.

- bugfix: Saving an ellipse lost any connectivity.

 

Version 4.6.59 release on 21/10/2018

- enhancement: Query dialog position and size saved between sessions.

- bugfix: Fixed a bug where, in non-OpenGL mode, creating an instance containing paths caused a crash.

 

Version 4.6.60 release on 22/10/2018

- enhancement: Overhaul of text engine. Both OpenGL and non-OpenGL canvases have similar (looking) implementation. Faster non-OpenGL drawing due to vector font.

- bugfix: Reshape Path had problems if the start or end segment of a path was reshaped.

- bugfix: Undo vertex stretch shifted original vertex.

- bugfix: DRD checking for single layer check did not exclude self.

- bugfix: In non-OpenGL mode, Create Label did not show label during cursor movement prior to a left click.

 

Version 4.6.61 release on 25/10/2018

- bugfix: Issue with labels in schematics fixed.

- bugfix: Labels with MX orientations drawn with MY and vice versa.

- bugfix: PCells could have duplicated shapes if properties changed and then changed back again.

 

Version 4.6.62 release on 29/10/2018

- bugfix: Fixed an issue in cdb::library::dbCopyCellView() where ellipse number of segments was not copied.

- bugfix: Ubuntu versions were built with a different version of python to the default installation, which caused infotools not to be loadable.

- bugfix: Paths with type ROUNDED were not drawn using fill pattern.

- bugfix: Polygons with holes sometimes did not draw with fill pattern.

- bugfix: Layout view labels were not directly scaled to dbu. Now a label's 'height' is as defined by its height attribute. Note that you might need to set the label size scale factor in the Display Options dialog for e.g. labels with a height of 1 now.

 

Version 4.6.63 release on 04/11/2018

- bugfix: Chop cmd didn't always create a hole, if a hole existed in the result.

- bugfix: Labels scaled by 1000x so a label with height of 1.0 displays as 1um. This makes label size compatible with Virtuoso.

- bugfix: OASIS reader/writer treated space as a non-printing character.

 

Version 4.6.64 release on 06/11/2018

- bugfix: Viewtypes of non-standard view names were not getting set when reading libraries.

- bugfix: OASIS reader set incorrect library dbu

- bugfix: Export CDL from a hierarchical netlist with parasitic capacitors gave same set of capacitors for every subcircuit.

- enhancement: Netlisting parasitic caps merges caps with pins swapped, and filters caps with pins on the same net.

 

Version 4.6.65 release on 16/11/2018

- bugfix: Arrays with certain row/col info could be read incorrectly.

 

Version 4.6.66 release on 09/12/2018

- bugfix: possible crash when evaluating a PCell failed.

- Schematic editor Add Wire cmd now shows a diamond when cursor is over a wire or pin.

- bugfix: geomContains did not correctly report shapes that were contained (inside but not touching) the other layer's shapes. NB this is different from geomInside which reports shapes that are inside (and possibly touching) the other layer's shapes.

 

Version 4.6.67 release on 14/12/2018

- bugfix: Incorrect OpenGL drawing could occur when drawing a design with via instances.

- bugfix: Generate Layout from schematics could crash if unbound PCell submasters in design.

- enhancement: Display of device properties can now be controlled by schematic Display Options dialog. Allows less cluttered schematics.

 

Version 4.6.68 release on 27/12/2018

- bugfix: Schematic check did not update instance name table correctly.

- bugfix: Using dual monitors could make app start offscreen in main display.

 

 

Contents|Index

Copyright © Peardrop Design 2020.