Glade Forum

Topic : Installing Glade on Windows


Posted By: Keith on August 2, 2008, 10:33 am
First download from: (32 bit windows) (64 bit windows)

Unzip the file to a directory on your PC, then follow the instructions in the README.txt file.

Edited by Keith : October 14, 2011, 1:39 pm

Posted By: mdill on January 19, 2010, 11:13 pm | Post: 1
Has anyone else had an issue with being unable to un-zip the 4.1.7 version ?
I get a file is invalid message from windows.

Thanks Mike D.

Edited by mdill : January 19, 2010, 11:20 pm

Posted By: Keith on January 20, 2010, 3:05 pm | Post: 2
Works fine for me. Maybe your download was corrupted?

Posted By: mdill on January 20, 2010, 4:03 pm | Post: 3
Thanks, My Explorer must have had a corrupt cached version, downloaded a few times with the same problem, cleared Explorer history and it downloaded without issue.
  User error :)

Thanks Mike D. 

Posted By: anandkrishpv on June 7, 2012, 4:54 pm | Post: 4
i am having issue with import of ui module. Glade is showing the following message whenever i am opening it.
# WARNING: Failed to import ui module - please check your PYTHONPATH!
# WARNING: PYTHONPATH is currently : D:\glade4_win32
I tried setting the environment variable PYTHONPATH to %GLADE_HOME% as told in the README.txt file but still the above message is coming up.
Glade version is 4.2.7 compiled on May 25 2012.

How can i fix it??

Edited by anandkrishpv : June 7, 2012, 5:00 pm

Posted By: Keith on June 7, 2012, 5:21 pm | Post: 5
Few things:

1) I assume you installed Glade at D:\glade4_win32 and set the environment variable %GLADE_HOME% to this dir, and %PYTHONPATH% so the same dir.

2) Do you have write permission to this directory? Is there the file in this directory, and is it readable?

3) Check that you are not running one version of Glade and pointing PYTHONPATH at another version of the file. This will also give the error you see.

Also I'd recommend downloading the latest 4.3.1 build, as there were a few issues with 4.2.7/4.3.0.



Edited by Keith : June 7, 2012, 5:24 pm

Posted By: anandkrishpv on June 8, 2012, 6:12 am | Post: 6
-->Point (1) was right. I did exactly the same thing.

-->Full control was set to the drive in which installed glade and is present in this directory which is in readable format.

-->Deleted all other versions of glade present.

Still the error is coming in windows.
By the way i switched to glade 4.3.1 as suggested. The same problem  is present in this version also.
Am i doing something wrong in setting the environment variables??


Edited by anandkrishpv : June 8, 2012, 6:13 am

Posted By: Keith on June 8, 2012, 6:34 am | Post: 7
Hard to say without further info. Make sure you delete any .pyc files from the installation, in case they are from a previous version. Or try installing in a different directory.

Posted By: anandkrishpv on June 8, 2012, 6:56 am | Post: 8
Tried installing in different directory also without any luck. Still the same error showing up.

One more thing is that whenever i am closing Glade application "Microsoft Visual C++ Runtime Library " window is popping up showing "Runtime error".

Posted By: Keith on June 8, 2012, 7:57 am | Post: 9
Ah, I have located the problem. The win32 version was missing the file '' (it is present in the win64 version). Without that, or a valid Python installation on your PC with '' in your PYTHONPATH, import ui failed.

I have fixed the distribution win32 version and uploaded it to the website.

Posted By: anandkrishpv on June 8, 2012, 8:11 am | Post: 10
Yes. That was it i guess.

But have a new problem now. Software is crashing after around 10 seconds. I need not do anything for the app to crash.

Posted By: Keith on June 8, 2012, 9:18 am | Post: 11
Log files? Crash dumps?

I find it hard to fix some bugs as i'm not telepathic! ;)

Posted By: anandkrishpv on June 8, 2012, 9:40 am | Post: 12
hehe.. ;)..

No files are getting created after crash i guess.

Posted By: Keith on June 8, 2012, 9:50 am | Post: 13
Well, with the latest build on a vanilla Windows 7 32 bit laptop, I get no crash. You did install the VC++ runtime DLLs? Although I wouln't expect it to even load without them.

Posted By: anandkrishpv on June 8, 2012, 10:00 am | Post: 14
i ran the file vcredist_x86 before starting installation although i had VC++ installed in my system. This should install VC++ runtime DLLs right??

Powered By AEF 1.0.9 © 2007-2011 Electron Inc.