Glade Reference


Change Log 2019

Contents for 2018 can be found here

 

Version 4.6.69 release on 12/01/2019

- enhancement: On Windows, setting the env var PYTHOMHOME overrides the bundled Python libraries/DLLs.

 

Version 4.6.70 release on 09/02/2019

- bugfix: Removed reporting labels as shapes with zero area in boolean engine.

- bugfix: Instances with magnification could be filtered out from display as filtering didn't consider magnification.

- enhancement: Added geomInteracts() boolean function.

- enhancement: Building edgeLayers in boolean engine speeded up.

- enhancement: geomNeighbours() DRC check for neighbouring contact/via spacing check.

 

Version 4.6.71 release on 26/02/2019

- bugfix: Fixed an error in boolean merging which could cause neighbour edge tracing errors.

- bugfix: Resistor extraction had terminals A and B but the optional third (bulk) terminal was also called B. It is now BULK.

 

Version 4.6.72 release on 28/03/2019

- bugfix: Cursor could change to left/right arrow on entering the app via a dock window.

- enhancement: Add Marker dialog now allows entering coordinates in DBU as well as microns. Makes it easier to cut&paste coordinates reported by some errors.

- bugfix: Calling Verify->Check a second time caused a crash.

 

Version 4.7.0 release on 05/04/2019

- enhancement: improved spatial database.

- enhancement: Import Oasis now allows either preserving paths or converting them to rectangles or H/VSegs.

- enhancement: Export Oasis now has options like Export GDS2 to output all layers, visible layers or a specified layer only.

- enhancement: Fast rendering for Window->Fit command.

 

Version 4.7.1 release on 08/04/2019

- bugfix: In partial select mode, with dynamic highlighting on, a crash could occur when a via instance would be highlighted.

- bugfix: dbCreateHole could fail with geometries that were non manhattan.

- bugfix: dbCreateHole now prefers vertical cutlines to equally preferred horizontal/vertical cutlines.

 

Version 4.7.2 release on 11/04/2019

- enhancement: Trace net can select shapes as well as highlight the traced net. Note than only shapes in the top level of the hierarchy can be selected.

- enhancement: HSeg/VSeg can have no net info. This gives reduced memory usage in import GDS2/OASIS when paths are converted to V/HSegs.

- bugfix: dbFindHierOverlaps() was not initialising filter size to 0. This could cause Trace Net to give incomplete results.

 

Version 4.7.3 release on 14/04/2019

- bugfix: rolled back fast window fit code as causing issues.

 

Version 4.7.4 release on 18/04/2019

- bugfix: Dim factor was not being read correctly from preferences file.

- bugfix: A Qt bug caused blitter not to release OpenGL context.

- bugfix: Loading a PCell via File->New Cell will reimport an already imported module. Previously if a PCell module had been imported, it would be reused.

- bugfix: Various issues with the World View tool fixed.

 

Version 4.7.5 release on 09/05/2019

- enhancement: Multi part paths can now have an OFFSET keyword to offset the MPP layer from the centreline by some value. Typically used if you want a MPP with two sets of contacts - by offsetting the contacts by +/- some value.

- enhancement: Multi part paths have a better algorithm for contact placement.

- enhancement: techfile getLayerOvlp/setLayerOvlp renamed getLayerExt/setLayerExt as this is an extension rule.

- enhancement: Importing a techfile can now replace or merge with existing technology.

- enhancement: Example PCells e.g. nch.py now written using rules derived from library techfile instead of hard coded rules in the PCell.

 

Version 4.7.6 release on 14/05/2019

- bugfix: Fixed a bug in dbCreatePCell that could cause a crash.

- bugfix: Fixed a bug in geomConnect that could give opens for some cases.

- enhancement: Gemini writes command line arguments on startup

- enhancement: Gemini writes MOS device W/L and XY coordinate (if present in input netlist) for unmatched devices.

 

Version 4.7.7 release on 22/05/2019

- bugfix: Crash occurred if PCell function name was different from the .py filename. Now gives error message.

- enhancement: Added an 'isValid' layer option to the techfile LAYER definition. Layers with isValid == 'f' will not be shown by default in the LSW.

- enhancement: Dynamic highlight shows the layer or instName of the highlighted object in the status bar.

- bugfix: Fixed a potential crash in dbGetOverlaps()

 

Version 4.7.8 release on 28/05/2019

- bugfix: Fixed a bounding box issue with paths that could cause them not to be displayed at certain zoom/positions.

- bugfix: Fixed a bug in geomNeighbours() that gave false errors.

- bugfix: Fixed a bug in geomSpace() with diffnet flag that gave false errors.

- bugfix: Fixed a bug with geom2DSpace() that gave incorrect parallel spacing errors.

- bugfix: Fixed a randon crash in geomArea()

 

Version 4.7.9 released on 14/06/2019

- bugfix: geomGetRectangles() / geomGetPolygons() returned a temporary which caused a crash.

 

Version 4.7.10 release on 19/07/2019

- bugfix: Net tracer did not add connectivity to vias with a missing layer stack shape.

- bugfix: Net tracer did not trace vias sometimes.

- bugfix: On non-manhattan shapes, net tracer could sometimes trace unconnected shapes.

- enhancement: Net tracer can now write out all traced shapes to a cellView. One or more traced nets can be written this way. Any assigned connectivity is also written.

- enhancement: A python interface to the net tracer has been added. ui.traceNet(cellView *cv, Point start, int mode, bool addConnectivity=False, char *netName=NULL, char *libName=NULL, char *cellName =NULL; char *viewName=NULL). mode is either 1 (just highlight the traced shapes), 2 (just select the top level traced shaped) or 3 (highlight the traced shapes, and write them to the cellView given by libName/cellName/viewName) A similar interface has been created for ui.traceLabel()

 

Version 4.7.11 release on 03/08/2019

- bugfix: Colinear path/poly point removal was retaining points that were on backtracks. This might make sense for some applications, but for the boolean processor it was causing major problems if such shapes existed (oFten the result of upsizing/downsizing). Therefore colinear backtrack points are now removed.

 

Version 4.7.12 release on 14/08/2019

- FIxed a Gemini bug where transistors with 3 terminals (bulk assumed) were gaining paramater mismatches.

- Fixed a new awkward bug in touch/abut of shape checks.

- Made monochrome work in PNG or SVG on graphical output of design data.

- fixed MINEXT in techfile so it actually works. Sets 'abut' flag off, so shapes that should extend but abut are flagged as errors.

- Improved error reporting for Verify->Check... commands.

 

Version 4.7.13 release on 30/09/2019

- implemented geomGetNet() command to get shapes connected to a specified net.

- Boolean ops transfer net info.

- geomGetShapes() sets net info into boolean engine if shapes in cellView have net info.

 

Version 4.7.14 release on 14/10/2009

- bugfix: Min area checkin had incorrect logic.

 

Version 4.7.15 release on 22/10/2019

- bugfix: geomLabel did not correctly pass net info to output layer

- bugfix: geomGetNet(layer, 'name') did not save net info to output layer

- enhancement: geomGetHoled(layer) outputs shapes to layer that contain holes. geomGetUnHoled() returns all shapes on layer without holes.

 

Version 4.7.16 release on 28/10/2019

- bugfix: Dynamic highlight was showing incorrect position of highlighted instances.

- bugfix: Closing a window using the window close button ignores 'Cancel' option in checkIfEdited dialog and closed regardless.

- bugfix: Edit in Place in non-OpenGL mode dimmed the EIP cell as well as other instances.

- bugfix: Instance/master name text in non-OpenGL mode too small.

- bugfix: When using dimming of unselected shapes, text labels could be drawn incorrectly.

- bugfix: Using the chop cmd on shapes with holes produced incorrect results.

- bugfix: Changing Display Options->Instance Names would reset display stop level if previously set by View->level 0 / View->level 99.

 

Version 4.7.17 release on 12/11/2019

- enhancement: Align tool has new spacing mode 'Layer Spacing' which takes the spacing for the reference object layer from the techfile minSpacing for that layer.

- enhancement: dbCreateNet() sets nets ending with '!' as global nets.

- bugfix: Fixed a crash if the LSW colour dialog was open and the application was hidden then shown.

 

Version 4.7.18 release on 02/12/2019

- bugfix: Zoomin out when viewing e.g a pin from the basic library failed due to rounding of the small world coordinate space. This is now fixed.

 

Version 4.7.19 release on 10/12/2019

- bugfix: When generating layout from schematic, the 'Create m factor instances' still created multiple instances if unchecked.

- bugfix: Two layer spacing/enclosure/extension rules were not read from library techfile.

- bugfix: 'Duplicate hash table entry' error could occur when processing shapes with holes..

 

Version 4.7.20 release on 17/12/2019

- bugfix: Create Wire cmd sometimes did not merge with existing wires correctly.

- bugfix: Create Wire cmd using the 'route' option could sometimes miss a segment when starting from a pin.

- bugfix: Create Path cmd using 'HV' or 'VH' snapping caused missing intermediate path point.

- bugfix: Fixed an issue where e.g. multiple layers could connect to another layer by the same via layer, e.g. active/poly1/poly2 to metal. Now you can change layer up in the Create Path command from any of the layers, but you can only change down from e.g. the metal layer to the next lower routing layer in the techfile, e.g. poly2.

- enhancement: Added ui().editFile() python command. With no arguments, opens a file chooser menu for a file to be edited. Or with a string argument, opens that file.

- enhancement: Glade text view/edit widget has line numbering.

 

 

Contents|Index

Copyright © Peardrop Design 2020.