Glade Reference


Change Log 2020

Contents for 2019 can be found here

 

Version 4.7.21 release on 18/01/2020

- enhancement: Edit window has python syntax highlighting

- bugfix: Export CDL wrote incorrect XY coords when using metres as scale factor.

- bugfix: Gemini wrote incorrect units in .err file for glade.

 

Version 4.7.22 release on 22/01/2020

- bugfix: Layer order now followed when drawing multiple layers. By default the layer order is as in the techfile/LSW, i.e. layers are drawn in order.

 

Version 4.7.23 release on 25/01/2020

- bugfix: Fixed a bug in compressPoints that could cause incorrect polygons with holes from dbCreateHole()

- bugfix: Fixed a bug in Edit->Chop that caused undo to fail

- bugfix: Switched on fast triangulation algorithm for OpenGL. Please report any issues rendering polygons as a result.

 

Version 4.7.24 release on 28/01/2020

- bugfix: Fixed a Python reference count issue in dbCreatePCell() that caused random instability, in particular in extraction.

- bugfix: Fixed a couple of memory leaks

 

Version 4.7.25 release on 21/02/2020

- enhancement: debugging using pdb no longer requires popup dialog for pdb commands; command can be typed directly into the message window cmd line.

- enhancement: enterprise version has file locking for multiuser environments.

- enhancement: dbCreateHole() has 2 new overloads:

shape = cv.dbCreateHole(Point *pts, int nPoints, int layer, shape *hull=NULL)

shape = cv.dbCreateHole(shape *hole, shape *hull = NULL)

- ellipse object has operator [], returning the point at index i

 

Version 4.7.26 release on 01/03/2020

- bugfix: layer valid attribute was not being saved/loaded to disk library.

- enhancement: new geomEdgeLength DRC check. Checks edges of one layer relative to edges of another layer, e.g.

geomEdgeLength(gate, active, 0.13, coincident, "Gate length < 0.13u")

This will check gate length (as the edge of the gate derived layer coincident with active).

 

Version 4.7.27 release on 09/03/2020

- bugfix: Undo did not work on deleted MPP.

- bugfix: MPP contact spacing algorithm improved.

- bugfix: Create MPP using infix mode did not choose last MPP rule.

 

Version 4.7.28 release on 26/03/2020

- bugfix: MPPs could have too many contacts in some situations

- enhancement: ui.addHilite() cmd now can take a net as its first argument. It then highlights all net shapes. This is for top level nets only i.e. no hierarchy tracing.

- enhancement: Added cv.dbFindInstsByRegExp(regexp), cv.dbFindNetsByRegExp(regexp) and cv.dbFindPinsByRegExp(regexp). These take a (string) regular expression as argument and find the objects matching the regExp.

- bugfix: Fixed a crash that could occur when adding a criteria to search dialog.

 

Verson 4.7.29 release on 16/04/2020

- enhancement: Stipple patterns internally held as 32x32 bit, but stipple pattern editor can now handle 8x8, 16x16, 32x32 pattern doisplay and editing.

 

Version 4.7.30 release on 21/04/2020

- bugfix: Issue reading fillstyles from old libraries caused by 4.7.29 bug.

- bugfix: Fixed some issues importing Cadence display.drf / techfile. Stipples 32x32 down to 4x4 supported (1 or 2 would be possible, but why...)

 

Version 4.7.31 release on 22/04/2020

- bugfix: layers with cross fill were not rendered as such in MPPs

- enhancement: Improved Cadence techfile parser for MPPs.

- enhancement: Support ordered spacing rules in Cadence techfiles.

- enhancement: Reuse linestyles. Previously reading a Cadence techfile could create 100's of (identical parameter) custom linestyles.

 

Version 4.7.32 release on 26/04/2020

- bugfix: Fixed a bug whereby the Query dialog was not always shown withing the current application window coordinates.

- enhancement: Keep library browser open at the current item when refreshed.

 

Version 4.7.33 release on 04/05/2020

- enhancement: Symbol editor Create Pin cmd can specify multiple pin names.

- bugfix: Export Verilog handles bus bit IOs from internal buses now using assign statements.

- bugfix: Crash occurred if a library was opened twice using dbOpenLib().

- bugfix: Changing an instance name to e.g. X0<7:0> when in spice compatible mode reverted to X0 during Create Instance. Now the bus info is retained.

- bugfix: Create Wire starting on a pin or instance pin did not snap to the origin or centre of the pin.

- bugfix: Fixed a bug where schematic check did not recognise buses with names containing e.g. numbers.

 

Version 4.7.34 release on 06/05/2020

- bugfix: Minor bugfix - problem when saving a library or techfile that caused stipple pattern to subtly change.

 

Version 4.7.35 release on 19/05/2020

- enhancement: -ng (no graphics) option uses QCoreApplication rather than QApplication so no widgets or gui stuff is created. All ui() cmds that require a gui will be ignored if in no graphics mode (e.g. selection, highlighting). All the File->Import and File->Export cmds can be used in no graphics mode.

 

Version 4.7.36 release on 25/05/2020

- bugfix: addProp() with a boolean or list property did not copy name, which could end up trashed.

- bugfix: Boolean properties shown on Query dialog / Create Instance dialog as true/false, not 1/0. PCell generation properly supports boolean parameters now.

- enhancement: New extraction cmds extractMOSDevice(), extractResDevice(), extractMosCapDevice(), extractBjtDevice(), extractDioDevice(). Similar to extractDevice() in that they accept a list of terminal layers and terminal name(s), but also have parameter extraction like extractMOS() etc. The terminal layer order must be adhered to e.g. gate, S/D, [bulk] for mosfets; anode, cathode, [bulk] for diodes; emitter, base, collector, [bulk] for bipolars. Note this also allows variable number of terminals per terminal layer.

 

Version 4.6.37 release on 05/06/2020

- bugfix: non-fatal exception was occurring while moving cursor over wires in schematic editor.

- bugfix: Crash in creating instance with DRD active in non-OpenGL mode.

 

Version 4.6.38 release on 16/06/2020

- bugfix: Fixed a potential crash with cmd line arguments.

- enhancement: pyLabel type labels now functional.

- bugfix: Mac version updated to Qt 5.15.0 to fix annoying window update bug.

 

Version 4.6.39 release on 27/06/2020

- bugfix: Various ui cmds failed in non-graphics mode.

- enhancement: ui cmds that do nothing / have no meaning in non-graphics mode issue an error message to the logfile.

- bugfix: Fixed various bugs in the DEF writer.

 

Version 4.7.40 release on 28/06/2020

- bugfix: Compare cells failed on cellviews containing only viaInsts or MPPs.

- bugfix: MPPs with layers using offset did not have offset displayed in query dialog

- bugfix: MPPs with duplicate layer definitions could not have layers edited correctly in query dialog.

- bugfix: Mfg grid (as defined in techfile) was not saved/loaded to library.

- bugfix: Gemini was not handling .scale / *.scale and property (w/l) scale factors such as um correctly.

 

Version 4.7.41 release on 10/07/2020

- bugfix: pyLabels could crash easily

- bugfix: pyLabels showed original, not evaluated test, when selected or highlighted.

- infrastructure: Glade moved to shared library model

 

Version 5.0.0 release on 18/07/2020

- Python3 support. Please note your PCells and/or Python code will need to be updated to python3 syntax. For example 'print x' becomes 'print(x)'. Python arithmetic changes mean that in the past, Rect(0, 3/2, 10, 5/2) will fail as 3/2 now returns a float (1.5) and the SWIG bindings are expecting an integer.

 

Version 5.0.1 release on 28/07/2020

- enhancement: Autoroute on schematic move. With the option set (in display dialog), moving an instance will show flight lines from the instance pins to the existing wiring; on finishing the move the instance pins are autorouted. Note this uses the autorouter, which requires schematic inst pins on the schematic snap grid to work. A schematic grid snap spacing of 0.0625 is recommended.

- enhancement: Merge schematic wire segments on stretch. Colinear points are now removed.

- bugfix: Various issues with the schematic autorouter fixed/improved. Point to point router has option of merging routed wires or maintaining separate routed wires.

- bugfix: Arc selection was not easy as the bounding box (for Qt) was the whole of the associated ellipse. Now for selection the bounding box of the arc geometry is used.

- bugfix: Fixed an issue with text bbox for selection not dependent on dbu (which is different for layout and schematic/symbols).

- enhancement: Stretch dialog 'Locks Ends' maintained during edit session.

- enhancement: Stretching a wire that ends on a solder dot now selects the solder dot so it is moved with the wire end.

- enhancement: Partial selecton mode allows selection of instances. This is so it can be used as default in the schematic editor, where selection of wire segments (and not the whole wire) plus instances and pins is the primary requirement.

- bugfix: Schematic diamond / cursor box would 'disappear' in partial select mode when highlighting was on.

- bugfix: Create wire when starting on an existing wire end in route mode did not mark existing wire as blockage.

- bugfix: If creating colinear points on wires, automatic removal would sometimes remove both colinear points, not just one.

 

Contents|Index

Copyright © Peardrop Design 2020.